Webserver software – PHP – 01 installeren

php logo

Op deze pagina wordt beschreven hoe je PHP 5.2.x kan installeren (windows).

Wat heb je nodig?
1) PHP 5.2.x ZIP bestand (Thread Safe)

Waarom het ZIP bestand?
– Het MSI bestand bevat niet de Apache DLL bestanden!

Dezelfde VC Build
Let goed op dat je dezelfde “VC build” hebt als apache, verschillende VC versies van beide programma’s zijn niet compatibel met elkaar!

Microsoft Visual Studio 6 (VC6)
Microsoft Visual Studio 2008 (VC9)
Microsoft Visual Studio 2010 (VC10)
Microsoft Visual Studio 2012 (VC11)
Microsoft Visual Studio 2015 (VC14)

Info (ENG):
VC10 – VC10 is the latest Visual Studio which supports XP and 2003, runs on: XP+, 7 SP1, Vista SP2, 8 / 8.1, 10, Server 2013+, Server 2008 SP2 / R2 SP1, Server 2012 / R2, Server 2016.

Waarom “Thread Safe” en niet “Non Thread Safe”?
Apache 2.2.x werkt alleen met “thread safe” PHP 5.2.x, anders krijg je dit te zien in de Apache logs:
“Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP. Pre-configuration failed”

1) Maak een folder aan (bijvoorbeeld C:\PHP5)
2) Decomprimeer dan het ZIP archief dat je zojuist gedownload hebt (de ingepakte bestanden) naar deze folder.
Decomprimeer het zo, dat het bestand php.exe zich in C:\PHP5\ bevindt.

Top